Thursday, June 13, 2013

Problem with wireshark 1.10.0 in Slackware 14

I just tried to compile wireshark 1.10.0 under Slackware64 14.0, using the build script from SBo.

It compiled fine, but running with segmentation fault.  It seems wireshark itself try to use libnl3 but libpcap in Slackwre is using libnl (version 1).  After adding configuration "--with-libnl=1" to force wireshark to use version 1 of libnl, it does not crash anymore.

But it did not use gnutls, it seems the version (3.0.23) in Slackware is too old, it required at least 3.1.10.  Currently, the latest stable version is 3.2.1, but it requires update nettle to 2.7 also.  I ended up update the gnutls lib to 3.1.12 to compile wireshark with tls support.

It seems Slackware-current does not update gnutls library yet, hope next version of Slackware could update the gnutls version to a newer one.

PS. seems nettle 2.7.1/gnutls 3.2.1/wireshark 1.10.0 works fine after I recompiled the 3 packages.

Post a Comment